Skip to content

CVE-2019-11580 — Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly…

Key facts

CVE-2019-11580 is a Critical (9.8) vulnerability: Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly…. This entry ships a detection-only PoC and a Docker test lab. It is on the CISA Known Exploited Vulnerabilities (KEV) catalog (added 2021-11-03), confirming active exploitation in the wild, and is linked to known ransomware campaigns.

Actively exploited — on the CISA KEV catalog

CVE-2019-11580 is listed on the CISA Known Exploited Vulnerabilities (KEV) catalog (added 2021-11-03), confirming exploitation in the wild. It is linked to known ransomware campaigns. Federal remediation deadline: 2022-05-03. Prioritise patching and deploy the detection and prevention rules below.

CVE CVE-2019-11580
Severity Critical (9.8)
CISA KEV Actively exploited (added 2021-11-03) · ransomware
Detection / prevention —
PoC poc.py
Source 2019/CVE-2019-11580/

Details

English | 한국어

Description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Vulnerability Details

Property Value
CVE ID CVE-2019-11580
CVSS Score 9.8

Proof of Concept

Download

# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2019/CVE-2019-11580/poc.py

Usage

# Run PoC against target
python3 poc.py --target <TARGET_URL>

# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>

⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.

Test Lab

This repository includes a Docker-based test environment with both vulnerable and patched applications.

Quick Start

# Clone and navigate to CVE directory
cd CVE-2019-11580

# Start both applications
docker-compose up -d

# Run tests
./run-tests.sh    # Linux/Mac
./run-tests.ps1   # Windows PowerShell

Application Endpoints

Application URL Status
Vulnerable App http://localhost:8080 Shows vulnerability
Patched App http://localhost:8081 Demonstrates fix

Directory Structure

├── README.md           # English documentation
├── README_KO.md        # Korean documentation
├── poc.py              # PoC detection script
├── docker-compose.yml  # Container orchestration
├── run-tests.sh        # Linux/Mac test runner
├── run-tests.ps1       # Windows test runner
├── vulnerable-app/     # Vulnerable version
│   ├── app.py
│   ├── Dockerfile
│   └── requirements.txt
└── patched-app/        # Fixed version
    ├── app.py
    ├── Dockerfile
    └── requirements.txt

References

  • http://packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html
  • http://www.securityfocus.com/bid/108637
  • https://jira.atlassian.com/browse/CWD-5388
  • http://packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html
  • http://www.securityfocus.com/bid/108637
  • https://jira.atlassian.com/browse/CWD-5388
  • https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11580

Generated by PoC Generator on 2026-07-02T09:05:18.210331578

Frequently asked questions

What is CVE-2019-11580?

CVE-2019-11580 is a Critical (9.8) vulnerability: Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly…. This entry ships a detection-only PoC and a Docker test lab. It is on the CISA Known Exploited Vulnerabilities (KEV) catalog (added 2021-11-03), confirming active exploitation in the wild, and is linked to known ransomware campaigns.

How do I detect CVE-2019-11580?

Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.

How do I block or mitigate CVE-2019-11580?

Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.

Is CVE-2019-11580 actively exploited?

Yes. CVE-2019-11580 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, added 2021-11-03, which means it has been exploited in the wild. CISA also links it to known ransomware campaigns. CISA set a federal remediation deadline of 2022-05-03. Prioritise patching and deploy the detection and prevention rules above.


For authorized security testing and research only. See the full source and NVD record.