CVE-2026-100720 — Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting.¶
Key facts
CVE-2026-100720 is a High (8.7) vulnerability: Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting.. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-100720 |
| Severity | High (8.7) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-100720/ |
Details¶
English | 한국어
Description¶
Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting. When a customer (the lowest-privileged authenticated role) uploads an SSL certificate for one of their own domains, the Certificates API add()/update() methods parse it with openssl_x509_parse() and store the issuer organization (issuer['O']) value verbatim without sanitization. Froxlor's table-listing renderer then emits scalar cells through Twig's raw filter, disabling HTML auto-escaping, so when an administrator or reseller opens Domains > SSL certificates the attacker-supplied issuer value executes as script in the privileged user's session. This crosses a privilege boundary from customer to admin and can result in full administrator account takeover; because a Froxlor admin controls webserver, DNS, and PHP configuration applied by a cron job running as root, the issue can be further escalated to command execution as root on the managed server. The issue is fixed in Froxlor 2.3.12.
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-100720 |
| Type | XSS |
| CVSS Score | 8.7 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-100720/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-100720
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://github.com/froxlor/froxlor/security/advisories/GHSA-89vj-gqqr-73p8
- https://www.vulncheck.com/advisories/froxlor-before-2.3.12-stored-xss-via-ssl-certificate-issuer
Generated by PoC Generator on 2026-09-26T23:41:34.097634342
Frequently asked questions¶
What is CVE-2026-100720?¶
CVE-2026-100720 is a High (8.7) vulnerability: Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting.. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-100720?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-100720?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.