CVE-2026-45414 — Decidim is a participatory democracy framework.¶
Key facts
CVE-2026-45414 is a High (8.5) vulnerability: Decidim is a participatory democracy framework.. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-45414 |
| Severity | High (8.5) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-45414/ |
Details¶
English | 한국어
Description¶
Decidim is a participatory democracy framework. Prior to 0.31.5 and in 0.32.0.rc1 before 0.32.0.rc2, JWT-backed API authentication is not bound to the organization selected by the current host, allowing a JWT issued for one tenant to be replayed against another tenant’s API to read participantDetails data and reach the proposal.answer mutation path. This issue is fixed in versions 0.31.5 and 0.32.0.rc2.
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-45414 |
| Type | IDOR |
| CVSS Score | 8.5 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-45414/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-45414
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://github.com/decidim/decidim/commit/023e206127c984a501345676e4789b31ddd115a1
- https://github.com/decidim/decidim/commit/226dc94894e6a3c030e4638c8b3441ee7199643c
- https://github.com/decidim/decidim/releases/tag/v0.31.5
- https://github.com/decidim/decidim/releases/tag/v0.32.0.rc2
- https://github.com/decidim/decidim/security/advisories/GHSA-r3v7-5x4c-c69q
- https://github.com/decidim/decidim/security/advisories/GHSA-r3v7-5x4c-c69q
Generated by PoC Generator on 2026-08-08T13:24:38.628634298
Frequently asked questions¶
What is CVE-2026-45414?¶
CVE-2026-45414 is a High (8.5) vulnerability: Decidim is a participatory democracy framework.. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-45414?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-45414?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.