Skip to content

CVE-2026-72730 — Discourse is an open-source discussion platform.

Key facts

CVE-2026-72730 is a High (8.7) vulnerability: Discourse is an open-source discussion platform.. This entry ships a detection-only PoC and a Docker test lab.

CVE CVE-2026-72730
Severity High (8.7)
Detection / prevention —
PoC poc.py
Source 2026/CVE-2026-72730/

Details

English | 한국어

Description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, the Rich Text Editor rendered a chat-transcript username as HTML, allowing stored cross-site scripting. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Vulnerability Details

Property Value
CVE ID CVE-2026-72730
Type XSS
CVSS Score 8.7

Proof of Concept

Download

# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-72730/poc.py

Usage

# Run PoC against target
python3 poc.py --target <TARGET_URL>

# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>

⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.

Test Lab

This repository includes a Docker-based test environment with both vulnerable and patched applications.

Quick Start

# Clone and navigate to CVE directory
cd CVE-2026-72730

# Start both applications
docker-compose up -d

# Run tests
./run-tests.sh    # Linux/Mac
./run-tests.ps1   # Windows PowerShell

Application Endpoints

Application URL Status
Vulnerable App http://localhost:8080 Shows vulnerability
Patched App http://localhost:8081 Demonstrates fix

Directory Structure

├── README.md           # English documentation
├── README_KO.md        # Korean documentation
├── poc.py              # PoC detection script
├── docker-compose.yml  # Container orchestration
├── run-tests.sh        # Linux/Mac test runner
├── run-tests.ps1       # Windows test runner
├── vulnerable-app/     # Vulnerable version
│   ├── app.py
│   ├── Dockerfile
│   └── requirements.txt
└── patched-app/        # Fixed version
    ├── app.py
    ├── Dockerfile
    └── requirements.txt

References

  • https://github.com/discourse/discourse/commit/32920affe4ad97b461ca2ae2f664c5fefc374baf
  • https://github.com/discourse/discourse/commit/3fb1e8ead0d4f48d2cf55c8110825c7e8a6a45f5
  • https://github.com/discourse/discourse/commit/7eb35d076ab9b6a612e86182336ce9787ce402ea
  • https://github.com/discourse/discourse/commit/9633b8ecaf5a99f0407f5261b9bd1a05f7dac529
  • https://github.com/discourse/discourse/security/advisories/GHSA-wg48-qxjc-f459

Generated by PoC Generator on 2026-08-11T03:21:44.807824006

Frequently asked questions

What is CVE-2026-72730?

CVE-2026-72730 is a High (8.7) vulnerability: Discourse is an open-source discussion platform.. This entry ships a detection-only PoC and a Docker test lab.

How do I detect CVE-2026-72730?

Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.

How do I block or mitigate CVE-2026-72730?

Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.


For authorized security testing and research only. See the full source and NVD record.