CVE-2026-72831 — The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect…¶
Key facts
CVE-2026-72831 is a High (8.8) vulnerability: The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect…. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-72831 |
| Severity | High (8.8) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-72831/ |
Details¶
English | 한국어
Description¶
The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-72831 |
| Type | RCE |
| CVSS Score | 8.8 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-72831/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-72831
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://github.com/getgrav/grav/commit/0b384f5b0e73b1ad9dd29c70185407895ea3b09f
- https://github.com/getgrav/grav/commit/8071c10bc3a4743a4b8cf003dfb1644d6680c2ea
- https://github.com/getgrav/grav/commit/a0bf26f7e5d7a98894b7cd2b8c5afe419b264e53
- https://github.com/getgrav/grav/commit/ad9709f865b09b68798fb1ac375b484a8cc1d892
- https://github.com/getgrav/grav/security/advisories/GHSA-pc8m-jxvh-vmrc
- https://www.vulncheck.com/advisories/grav-through-authentication-bypass-via-flex-objects
Generated by PoC Generator on 2026-08-15T01:23:51.241564357
Frequently asked questions¶
What is CVE-2026-72831?¶
CVE-2026-72831 is a High (8.8) vulnerability: The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect…. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-72831?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-72831?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.