CVE-2026-8445 — justhtml versions <= 1.11.0 (fixed in 1.12.0) do not sufficiently escape HTML-significant…¶
Key facts
CVE-2026-8445 is a Critical (9.8) vulnerability: justhtml versions <= 1.11.0 (fixed in 1.12.0) do not sufficiently escape HTML-significant…. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-8445 |
| Severity | Critical (9.8) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-8445/ |
Details¶
English | 한국어
Description¶
justhtml versions <= 1.11.0 (fixed in 1.12.0) do not sufficiently escape HTML-significant characters (angle brackets) in text nodes when converting a parsed document to Markdown via to_markdown(). While a small set of Markdown metacharacters are escaped, characters such as < and > are preserved, so untrusted input that is safe in to_html() — including entity-decoded text (e.g. <script>) or text from RCDATA/RAWTEXT-parsed elements like