CVE-2026-92940 — vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to…¶
Key facts
CVE-2026-92940 is a Critical (10.0) vulnerability: vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to…. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-92940 |
| Severity | Critical (10.0) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-92940/ |
Details¶
English | 한국어
Description¶
vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-92940 |
| CVSS Score | 10.0 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-92940/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-92940
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://github.com/patriksimek/vm2/security/advisories/GHSA-h85j-hv3c-qfgq
- https://www.vulncheck.com/advisories/vm2-3.11.3-through-3.11.6-https-credential-exposure-via-globalagent
Generated by PoC Generator on 2026-09-18T07:30:59.930241346
Frequently asked questions¶
What is CVE-2026-92940?¶
CVE-2026-92940 is a Critical (10.0) vulnerability: vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to…. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-92940?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-92940?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.