CVE-2026-92957 — vm2 through 3.11.6 does not normalize node:-prefixed builtin specifiers when evaluating…¶
Key facts
CVE-2026-92957 is a Critical (9.9) vulnerability: vm2 through 3.11.6 does not normalize node:-prefixed builtin specifiers when evaluating…. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-92957 |
| Severity | Critical (9.9) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-92957/ |
Details¶
English | 한국어
Description¶
vm2 through 3.11.6 does not normalize node:-prefixed builtin specifiers when evaluating user-supplied negative (deny) entries in a NodeVM wildcard require policy. Although NodeVM strips the node: prefix during require() resolution, negative wildcard entries are matched by exact string comparison against the canonical builtin names, so a policy such as new NodeVM({ require: { builtin: ['*', '-node:child_process'] } }) fails to deny the canonical child_process module. Sandboxed code can therefore obtain the host child_process builtin via require('child_process') or require('node:child_process'), gaining references to process-spawning APIs such as execSync and spawn, which is equivalent to host command-execution capability for untrusted sandbox code. Fixed in vm2 3.11.7. (Suggested title: "vm2 before 3.11.7: NodeVM builtin deny-list bypass via node:-prefixed specifiers exposes child_process")
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-92957 |
| CVSS Score | 9.9 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-92957/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-92957
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://github.com/patriksimek/vm2/security/advisories/GHSA-8686-vhfx-7r3j
- https://www.vulncheck.com/advisories/vm2-before-3.11.7-authentication-bypass-via-node-prefix
Generated by PoC Generator on 2026-09-18T00:12:47.294831883
Frequently asked questions¶
What is CVE-2026-92957?¶
CVE-2026-92957 is a Critical (9.9) vulnerability: vm2 through 3.11.6 does not normalize node:-prefixed builtin specifiers when evaluating…. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-92957?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-92957?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.