CVE-2026-96883 — pgcollection is an open source extension to PostgreSQL.¶
Key facts
CVE-2026-96883 is a High (8.8) vulnerability: pgcollection is an open source extension to PostgreSQL.. This entry ships a detection-only PoC and a Docker test lab.
| CVE | CVE-2026-96883 |
| Severity | High (8.8) |
| Detection / prevention | — |
| PoC | poc.py |
| Source | 2026/CVE-2026-96883/ |
Details¶
English | 한국어
Description¶
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.
To remediate this issue, users should upgrade to version 2.1.2 or later.
Vulnerability Details¶
| Property | Value |
|---|---|
| CVE ID | CVE-2026-96883 |
| Type | RCE |
| CVSS Score | 8.8 |
Proof of Concept¶
Download¶
# Download PoC script
curl -O https://raw.githubusercontent.com/fankh/vulnerability-poc/main/2026/CVE-2026-96883/poc.py
Usage¶
# Run PoC against target
python3 poc.py --target <TARGET_URL>
# With authentication
python3 poc.py --target <TARGET_URL> --username <USER> --password <PASS>
⚠️ Warning: This PoC is for authorized security testing only. It uses detection-only techniques and does not exploit or damage target systems.
Test Lab¶
This repository includes a Docker-based test environment with both vulnerable and patched applications.
Quick Start¶
# Clone and navigate to CVE directory
cd CVE-2026-96883
# Start both applications
docker-compose up -d
# Run tests
./run-tests.sh # Linux/Mac
./run-tests.ps1 # Windows PowerShell
Application Endpoints¶
| Application | URL | Status |
|---|---|---|
| Vulnerable App | http://localhost:8080 | Shows vulnerability |
| Patched App | http://localhost:8081 | Demonstrates fix |
Directory Structure¶
├── README.md # English documentation
├── README_KO.md # Korean documentation
├── poc.py # PoC detection script
├── docker-compose.yml # Container orchestration
├── run-tests.sh # Linux/Mac test runner
├── run-tests.ps1 # Windows test runner
├── vulnerable-app/ # Vulnerable version
│ ├── app.py
│ ├── Dockerfile
│ └── requirements.txt
└── patched-app/ # Fixed version
├── app.py
├── Dockerfile
└── requirements.txt
References¶
- https://aws.amazon.com/security/security-bulletins/2026-118-aws/
- https://github.com/aws/pgcollection/releases/tag/v2.1.2
- https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r
Generated by PoC Generator on 2026-09-27T08:26:16.376263078
Frequently asked questions¶
What is CVE-2026-96883?¶
CVE-2026-96883 is a High (8.8) vulnerability: pgcollection is an open source extension to PostgreSQL.. This entry ships a detection-only PoC and a Docker test lab.
How do I detect CVE-2026-96883?¶
Run the detection-only PoC included with this entry against your Docker test lab to confirm whether a target is affected; pair it with your own IDS logging.
How do I block or mitigate CVE-2026-96883?¶
Upgrade to a fixed version per the vendor advisory; the NVD record lists the affected versions. Use the included PoC to verify your remediation.
For authorized security testing and research only. See the full source and NVD record.